iOS 12.5.4 corrige des problèmes de sécurité importants

Mickaël Bazoge |

En plus des bêtas du soir, Apple fournit une nouvelle version d'iOS 12 pour tous les appareils, iPhone comme iPad, qui ne peuvent être mis à jour avec iOS 13. Il s'agit d'iOS 12.5.4 et de son équivalent iPadOS, qui portent le numéro de build 16H50. Sont concernés les iPhone 5s, 6 et 6 Plus, ainsi que l'iPad Air, l'iPad mini 2 et l'iPad mini 3, et l'iPod touch 6e génération.

Cette nouvelle version apporte des correctifs de sécurité importants, explique Apple dans son style sibyllin habituel. On aura sans doute plus d'informations dans la soirée.

Mise à jour — Apple a mis en ligne la fiche d'assistance concernant le contenu sécurité d'iOS 12.5.4, qui corrige trois failles : deux pour WebKit, une pour Safari.


Tags
avatar Florent Morin | 

Les fameux 1 %…

avatar romainB84 | 

OBSOLESCENCE PROGRAMEEEEEEEEEEE
APPPLE DE LA MEEEEEERDE
ah mince... je me suis trompé de compte ^^

avatar reborn | 

@romainB84

🤣

avatar Camilla | 

@romainB84

🤣🤣🤣🤣

avatar Sindanárië | 

@romainB84

Anonx ça suffit, on t’as vu

avatar romainB84 | 

@Sindanárië

avatar Sindanárië | 

@romainB84

Ah pardon, excuse moi clownworld 🤡

Bah oui le polo pêche écrasée avec le pantalon remonté jusque sous les seins ça trompe pas 😁

avatar romainB84 | 

@Sindanárië

2 de mes comptes de démasqués 🤣

avatar Chris_974 | 

Chapeau à Apple qui n’oublie pas les vieilles versions. Quand il faut le dire, il faut le dire.

avatar AKZ | 

Je dirai merci à Apple le jour ou on pourra downgrader iOS.
iOS 12 à littéralement scotché l’iPad air quand celui-ci était une vraie bombe jusqu’à iOS 10.

avatar redchou | 

Corrige aussi les failles pour le prochain Jailbreak? 🧐
Édit: Vu les notes de mise à jour, oui, les failles WebKit et safari permettent un nouveau jailbreak dans le navigateur, Apple a du réagir vite… 😅

avatar draco1544 | 

@redchou

"Édit: Vu les notes de mise à jour, oui, les failles WebKit et safari permettent un nouveau jailbreak dans le navigateur, Apple a du réagir vite… 😅"

Le jailbreak (en plus dans un navigateur) est une grosse faille de sécurité, ça permet de prendre le contrôle de l’appareil de l’utilisateur et de lui installer n’importe quoi

avatar redchou | 

@draco1544

Oui, c’est très dangereux… 😉
Pour cela qu’Apple a du réagir vite…

avatar Lu Canneberges | 

L’iPhone 5s est sorti en 2013 et reçoit toujours des mises à jours capitales en 2021 !!

Pendant ce temps il se passe quoi sur un paquet d’Androids de ne serait-ce que 2020, 2019, 2018 ?! Et alors les Androids de 2015 ça doit être des passoires monstrueuses…

Bref, chapeau, et je pense qu’Apple devrait commencer à mettre cela fortement en avant dans sa communication, c’est vraiment un point fort et qui reste invisible malgré son importance…

avatar Hugofloflo | 

@Lu Canneberges

C’est bien beau mais si les applications sont incompatibles cause de l’os obsolète …bah désolé mais android n’a pas ce problème ! Les applis peuvent toujours fonctionner et être mises à jour

avatar romainB84 | 

@Hugofloflo

Il me semble qu’à une époque on pouvait télécharger la « dernière » version des applications en fonction de l’os ou on se trouve. Mais qu’ils avaient viré ça après

avatar lolo81 | 

@romainB84

Non, c'est toujours le cas 👍🏻pour certaines ! Pas pour toutes
Par exemple Runkeeper
Voulez vous télécharger la dernière version compatible avec votre système ?
Mais malheureusement ce n'est pas le cas pour toutes les applications
Bon il faut dire que je suis encore sur un 5C , donc iOS 10 😊
Tant que mon appli de sport 🏃🏻🚴fonctionne ça me donne une raison de conserver mon iphone 😉
Même si je ne dois pas avoir toutes les nouvelles fonctions des dernières mises à jours de Runkeeper 😆

avatar romainB84 | 

@lolo81

« Mais malheureusement ce n'est pas le cas pour toutes les applications »
Comment cela se fait il?
C’est pas l’OS qui décide quelle version de l’appli tu peux télécharger ?
Ça serait un verrouillage de la part du dev de l’appli du coup?

avatar lolo81 | 

@romainB84

Oui je pense !
Car il y a plein d'autres applications que je ne peu plus télécharger
Il faut iOS 11 à minima
Dont une qui ne fonctionnait plus qui me demandais de mettre à jour iOS
Je pense qu'à un moment les développeurs se focalisent sur les derniers OS ce qui est normal
Mais c'est vraiment chouette quand une version est compatible et disponible avec ton viel iphone 🙂

avatar romainB84 | 

@lolo81

Qu’ils se focalisent sur les derniers OS, ça se comprend, mais ils peuvent tout de même laisser la permission de télécharger une vielle version quand les nouvelles ne sont plus compatibles avec l’OS de l’utilisateur. Qu’est ce que ça leur fait? De toute façon… ils ne pourront pas utiliser leur applis sinon… donc c’est tout bénéf pour le dev d’autoriser ça (même si l’utilisateur n’a une version qui n’est plus mise à jour ou limitée en fonction… c’est toujours mieux que rien).
Ça doit être une contrainte technique côté serveur chez le dev je pense. Si ils font des modifs côté serveurs qui rendent les anciennes versions non compatibles.

avatar idhem59 | 

@romainB84

J'imagine que pour les nombreux cas où version obsolète signifie aussi risque de sécurité, c'est un peu plus compliqué que ça.

Ça se discute évidemment, mais ça ne me parait pas si déconnant d'interdire l'accès officiel à des versions potentiellement vulnérables des applications.

avatar romainB84 | 

@idhem59

Tu mets un gros disclamer au lancement de l’appli !
Après a l’utilisateur d’en assumer la responsabilité : il a les infos … il prend ou il ne prend pas mais il a le choix. (c’est évident que les devs ne vont pas assurer la mise à jour de secu pendant 15 ans non plus!) mais je me dis que pour certains app/jeux ça aurait pu être cool.

avatar lolo81 | 

@romainB84

Oui je suis d'accord !
Il est certain que c'est vraiment extra de pouvoir avoir les versions compatibles sur de vieux appareils
Comme mon appli de sport 👍🏻
Mais je n'ai aucune idée des contraintes techniques ou de celles imposées par Apple

avatar idhem59 | 

@Hugofloflo

On parle quand même ici d'appareils qui ont 7/8 ans, et iOS 12 sera encore compatible avec plus ou moins toutes les applications pendant encore un moment.
On ne va quand même pas se plaindre si un iPhone 5S se retrouve incompatible avec les applications presque 10 ans après sa sortie.

Par contre, mon vieux LG G2, contemporain du 5S et qui coûtait quasiment le même prix n'a jamais dépassé officiellement Android 5.0, n'a pas reçu la moindre MAJ de sécurité depuis 2015, et sa compatibilité avec les applications et technos logicielles modernes est largement discutable. C'est un exemple le G2, mais à peu près tout ses contemporains en sont plus ou moins au même point aujourd'hui.

avatar draco1544 | 

@Hugofloflo

"C’est bien beau mais si les applications sont incompatibles cause de l’os obsolète …bah désolé mais android n’a pas ce problème ! Les applis peuvent toujours fonctionner et être mises à jour"

Car du coter d’android ils n’introduisent que très rarement de gros changement technique et de nouveaux outil pour faciliter la vie des dev (swift ui) donc on ce retrouve toujours avec les mêmes app avec le même design vieillissant très rarement mis à jour

avatar klouk1 | 

@Hugofloflo

Ben pas chez moi. J’ai des applications qui ne tournent pas sur Android 8

avatar mat16963 | 

@Lu Canneberges

Et du côté de macOS, la différence fait aussi mal: mon iMac de fin 2013 n’a plus qu’un an de màj… alors qu’il est encore tout à fait capable.

J’espère que cela va changer avec Apple Silicon, car là où Apple est exemplaire avec l’iPhone, elle fait partie des pires élèves avec le Mac…

avatar killabling | 

On a toujours droit aux maj de securités mm après 5ans...!!!
Mais pas forcément de l'OS,comme chez Apple,heinnn.

avatar Hugofloflo | 

Je tiens à signaler que j’utilise iOS et android et je constate des avantages dans les deux ! Je n’ai pas de partis pris

avatar spezzic | 

Et les bugs de 12.5 ? Parce que mon iphone 12 pro a pris un sacré coup avec cette mise a jour !

avatar Boboss29 | 

@spezzic

IPhone 12 pro sur ios 12 ? 😱

avatar romainB84 | 

@Boboss29

Il a une version collector 😍

avatar anonx | 

OUF des mises à jour !

C’est que ça veut dire que ça fonctionne bien… 🤡

Regardez les commentaires sur l’app store de l’appli HUE qui vient d’être mise à jour 🥴🤣🤣🤣

CONNEXION UTILISATEUR