En mars 2019, les apps devront être développées avec les derniers SDK et supporter les nouveaux appareils

Mickaël Bazoge |

Les développeurs vont avoir du pain sur la planche dans les prochains jours, avec la sortie des versions finales d’iOS 12, watchOS 5 et tvOS 12 prévues pour le 17 septembre. Apple leur met gentiment la pression en indiquant qu’ils peuvent désormais soumettre à l’App Store leurs applications destinées aux nouveaux systèmes d’exploitation.

Idem d’ailleurs pour les développeurs Mac pour le nouveau Mac App Store de macOS Mojave (la version finale est attendue pour le 24 septembre). Le constructeur propose la GM de Xcode 10 depuis hier soir.

Apple précise aussi qu’à partir du mois de mars 2019, toutes les nouvelles apps et les mises à jour des apps existantes destinées à l’iPhone devront être bâties avec le SDK d’iOS 12 et prendre en charge l’iPhone Xs Max. Une date butoir identique pour les développeurs d’apps watchOS, celles-ci devront avoir été conçues avec le SDK de watchOS 5 et supporter les Apple Watch Series 4.

avatar Julien Lavergne | 

Enfin une décision couillue !

avatar Finouche | 

Justement, pour pouvoir installer Xcode 10 sur un Mac Pro 2008 patché 5,1 et déjà sous Sierra, il faudrait que je passe à High Sierra.

Question : La mise à jour se fait directement ? Sans bidouilles ? Sans soucis ? Les doigts dans nez ?
Merci.

avatar Link1993 | 

@Finouche

Si c'est avec la mise à jour firmware pour le faire passer en 5.1, pas de soucis. Sauf que c'était avec le modem 2009 qu'on pouvait faite ça, pas 2008 :/

avatar Finouche | 

C'est bien un Mac Pro 2008 4,1 mis à jour en 5,1 early 2009 et affiché comme tel dans les infos système. Le truc c'est que l'installateur de High Sierra demande de faire une mise à jour du firmware avant l'installation. C'est ce qui m'inquiète, bien que l'on trouve des témoignages d'installation réussie.
https://apple.stackexchange.com/questions/299769/mac-pro-4-1-flashed-hig...

avatar r e m y | 

Apple va devoir à nouveau mettre à jour l'utilitaire Airport et Remote!

Tout ce boulot, ça va encore décaler la sortie du AirPower... ☹️

avatar Alberto8 | 

@r e m y

Ça n’a rien a voir je pense 🤔🤓🧐

avatar armandgz123 | 

@Alberto8

C’est ironique !

avatar ovea | 

L'AirPowder ressort du placard

avatar Mrleblanc101 | 

@r e m y

Ils sont déjà à jour...

avatar r e m y | 

@Mrleblanc101

Pas pour les nouvelles dimensions d'écran, si?

avatar Wolf | 

Autant je suis déjà sur iOS12 et je passerais vite a TVOS 12 et WatchOS 5, autant je ne vais pas me presser pour OSX ...

avatar ovea | 

Très juste, par exemple :
tu pars en antarctique faire tout ce qu'il y a de plus utile et en revenant, tu te rends compte que ton Mac, ton iPhone et tout le reste estampe-pillé d'une pomme, t'oblige à des mises à jour qui te font penser avoir passé deux ou trois cycles glaciers
… au cour des trois cent mille ans, tu aurais donc vu naître et mourir deux cycles de civilisations humaines, se repliants tantôt sur la bande étroite équatoriale, tantôt se déployant au plus chaud des vingt mille ans (comme aujourd'hui après dix mille ans) partout sur la planète
… et là tu te dis que malgré toute la mémoire échantillonnée dans la plus débile… fébrile des technologies et bien, comment dire
… haaa, ouiii ! Les glaciers vont bien abraser toutes ces créa… constructions humaines et remettre tout à zéro
Bref !
De quoi se refaire un : Lilo et Stitch, rien que pour le passage où, d'un exo-point de vu, la seul espèce protégée sur terre est celle des moustiques

avatar outmen | 

Eh bien tant pis, on ne proposera plus de mises à jour ... voilà. Non là vraiment c’est trop coercitif ça me saoule.

avatar quentinf33 | 

@outmen

Ou est le problème en fait ?

avatar moa_toa | 

@quentinf33

Le problème vient de l’obligation d’adapter ses app au nouveaux iPhone et Apple Watch en mars 2019 donc impossible de faire une simple correction d’app mais une mise à jour "majeure" de cette application donc en gros tu te fais chier pour la rendre compatible avec iOS 12 et à peine elle sera stable que faudra la rendre compatible avec l’iPhone Xs et Xr...

avatar r e m y | 

@quentinf33

Si outmen ne met plus à jour ses apps, le problème ne sera pas immédiat mais va apparaître quand Apple supprimera l'app de son store au motif qu'elle n'a pas été mise à jour depuis un certain temps.

avatar quentinf33 | 

@r e m y

Ils recevront des mails bien avant. Moi ça me parait normal d’utiliser le dernier SDK. Rien à dire ou à débattre de mon côté. Les arguments qui m’ont été donnés ne sont pas valables selon moi.

avatar ovea | 

La seul manière de développer n'est pas celle attachée aux chaînes d'un colosse
… mais celle consistant à écrire du code avec des paradigmes qui se réécrivent de façon autonome en fonction de la cible
🎯
À tout bon chasseur de codes

avatar brunnno | 

Aujourd’hui encore, un an après la sortie de l’iPhone X, de nombreuses applications ne sont pas au bon format...

CONNEXION UTILISATEUR