iOS 6 : les incompatibilités selon le modèle d'iPhone et d'iPad

Stéphane Moussie | | 16:25 |  162

Comme pour chaque version majeure d'iOS, les terminaux les plus anciens supportés sont privés de certaines nouvelles fonctionnalités. En 2010, l'iPhone 3G ne pouvait pas gérer plusieurs fonctions introduites dans iOS 4 comme le multitâche, la prise en charge des claviers Bluetooth, et, plus surprenant, la personnalisation du fond d'écran (lire : iOS 4 : ce qui ne marche pas avec l'iPhone 3G).

iOS 5 avait lui aussi son lot de fonctions réservées aux produits Apple les plus récents. On citera bien sûr Siri, disponible exclusivement pour l'iPhone 4S, et les rappels géolocalisés non supportés par l'iPhone 3GS et le premier iPad (lire : iOS 5 : quelles incompatibilités pour les anciennes générations ?).

La sixième version du système d'exploitation mobile est disponible pour iPhone 3GS/4/4S, iPod touch 4ème génération, iPad 2 et nouvel iPad.

Qu'en est-il des incompatibilités pour chaque terminal ? Revue des fonctions auxquels vous pourriez ne pas avoir accès en fonction de votre iPhone ou iPad.

Siri débarque sur le nouvel iPad
L'assistant vocal d'iOS jusque-là réservé à l'iPhone 4S arrive sur le nouvel iPad avec iOS 6. Pas de miracle toutefois pour les terminaux plus anciens (iPhone 3GS/4 et iPad 2), ils ne sont toujours pas supportés.

Plans : vue aérienne en 3D et mode conduite pour iPhone 4S, iPad 2 et nouvel iPad
Tout le monde ne pourra pas profiter des nouvelles fonctionnalités de Plans. L'application de cartographie qu'Apple a entièrement revue intègre Flyover, une vue aérienne en 3D, qui nécessite un iPhone 4S ou un iPad 2 minimum.

Même constat pour le mode conduite (turn-by-turn navigation) qui ne fonctionne ni sur iPhone 3GS, ni sur iPhone 4 — c'est bien évidemment le cas aussi pour l'iPod touch.


Plans : iPhone 4S à gauche, avec le bouton 3D - iPhone 3GS à droite, sans le bouton 3D

FaceTime en 3G, seulement pour l'iPhone 4S et le nouvel iPad
Le chat vidéo d'Apple peut enfin fonctionner en 3G grâce à iOS 6... mais exclusivement sur l'iPhone 4S et sur le dernier iPad. L'iPad 2 et l'iPhone 4 qui possèdent pourtant tous deux une caméra frontale ne permettent pas de communiquer en vidéo sans se connecter à un réseau Wi-Fi.

iOS 6 aminci pour l'iPhone 3GS
L'iPhone 3GS, sorti en 2009, se voit privé d'autres fonctionnalités propres à iOS 6. Ainsi, les contacts VIP, la liste de lecture hors ligne et le partage du flux de photos ne sont pas disponibles sur l'iPhone vétéran.


Partage d'images : iPhone 4S à gauche - iPhone 3GS à droite, sans le partage du flux de photos et l'envoi par Message

[MàJ] : un lecteur, 28guillaume28, nous a indiqué que le partage de flux de photos n'était pas non plus disponible sur iPhone 4. Or, Apple indique bien sur son site que la fonctionnalité est disponible à partir de l'iPhone 4. Il peut s'agire d'un bug ou d'un oubli qui sera peut-être corrigé dans une prochaine bêta d'iOS 6.

Sur le même sujet :
- Aperçu en images d'iOS 6 : première partie
- iOS 6 : aperçu de Plans

Catégorie : 

Les derniers dossiers sur iGeneration

Ailleurs sur le Web


162 Commentaires Signaler un abus dans les commentaires

avatar misterbrown 14/06/2012 - 16:38

C'est sûr, un iPhone 4 ne peut absolument pas supporter de logiciels GPS...

avatar misterbrown 14/06/2012 - 16:38

Doublon.

avatar 1singe/hiver 14/06/2012 - 16:41 via iGeneration pour iPhone

@Akerloof : 'Les anciens appareils n'ont pas la capacité de faire tourner des modes comme la 3D ou la navigation (très consommatrice en ressources système)..' Il ne faut pas exagérer non plus ! Comment font tous les navigateurs GPS depuis l'iPhone 3G ?

avatar pacou 14/06/2012 - 16:42

C'est beau d'être convaincu par ce que l'on dit même quand ça n'a aucun sens... Pour la 3D l'iPhone 3GS est bien assez performant (c.f. la multitude de jeux qui tournent dessus) Pour la navigation on a pas attendu Apple pour faire tourner TomTom dessus et cela fonctionne très bien. Quand a Siri il fonctionne parfaitement avec un iPhone 4 jailbreaké et non il n'y a pas de puce de traitement spé dans le 4S... C'est gentil de faire le mouton et de vouloir défendre Apple bec et ongles mais la c'est juste soûlant. Apple pratique l’obsolescence programmée comme tous les autres constructeurs, et toutes ces limitations ne sont pas des questions de matériel mais uniquement de marketing. Point barre. Pour ceux qui voudront garder leur appareil et avoir accès à ces nouvelles fonctions le jailbreak sera toujours là.

avatar hdub 14/06/2012 - 20:45 via iGeneration pour iPad

@Akerloof Non c'est purement marketing ! Mais il faut pas se plaindre non plus, sur les téléphones Android, ceux-ci sont rarement mise à jour.

avatar psykopat 15/06/2012 - 15:09

Tu fais partie de ces endormis qui n'ont pas compris que Siri PEUT tourner sur un iPhone 4 également (des gens l'ont déjà fait en jailbreakant leur iPhone 4), et qu'Apple adore les astuces Marketing du genre (de leurs propres avoeux). Il n'y a pas de "puce" magique qui fait tourner Siri. Fais un tour sur Google et tu verras.

avatar master_bate 14/06/2012 - 16:33

Eh bien, il est temps que je remplace mon iPhone 4 par le prochain.

avatar max68lola22 14/06/2012 - 16:34 via iGeneration pour iPad

ceci est une révolution il faut tout racheter argent trop cher lalala...Téléphone ....c'est de circonstance

avatar le_hobbit 14/06/2012 - 16:34 via iGeneration pour iPhone

En gros : rien pour le 3GS sauf le nom iOS6.

avatar marcplemay 15/06/2012 - 14:34

M'etonnerai pas qu'il y ai une perte de fluidité en sus ...

avatar winstonsmith 14/06/2012 - 17:05 via iGeneration pour iPad

@negaca 'En gros : rien pour le 3GS sauf le nom iOS6.' Si : des APIs iOS 6 et une compatibilité rallongée avec toutes les applis de l'AppStore. Très important, au contraire. '"L'application de cartographie qu'Apple a entièrement revue intègre Flyover, une vue aérienne en 3D, qui nécessite un iPhone 4S ou un nouvel iPad." Ça veut donc dire que l' iPod touch 4g ( le dernier de la gamme) ne fonctionnera pas avec Flyover??!!! Ça commence à m'énerver!!! Je l'ai justement acheté pour qu'il ait toutes les nouveautés d'iOs 6&7!!' Loin de moi l'idée de défendre la politique d'Apple, mais acheter un modèle qui a deux ans en espérant avoir encore 2 ans de MàJ complètes, c'est...comment dire...

avatar eipem 14/06/2012 - 18:05

Un peu comme sur les téléphones Androids Samsung ou HTC qui ont moins de 2 ans mais qui n'auront même pas droit à leur mise à jour ICS sorti il y a 8 mois en fait. Don't Be Evil...

avatar valentin. 14/06/2012 - 16:36

Les limitations suite aux contraintes techniques, je comprends naturellement. Les limitations volontaires pour booster les ventes de leurs nouveaux appareils sont une honte. Don't be evil.

avatar eldaran83 14/06/2012 - 16:51

Apple abuse. Franchement. Ne serait-ce que pour les VIPs (une simple fonction logicielle) ou le partage. Le pire selon moi est FaceTime via 3G, promis avant l'iPhone 4$ par Steve Jobs. C'est une arnaque. (Et on oublie evidemment pas le ralentissement du système qui va bien, pour forcer l'utilisateur...)

avatar eldaran83 14/06/2012 - 17:12

@ Steeve J. : Mais pas pour l'iPhone 4S... Bien sûr...

avatar napuconcture 14/06/2012 - 17:13

Pourquoi ils ne bloquent pas sur Android ?

avatar Burling 14/06/2012 - 23:39 via iGeneration pour iPad

@theodoub Donc tu achètes un produit à l'avance pour être sur qu'il fonctionne avec des os qui ne sortiront que dans un ou deux ans? Tu m'épates. Je suis d'accord que l'on soit déçu, mais il faut également accepté que lorsque l'on achète un appareil, on l'achète sous une certaine forme. Les MaJ ne pourraient après tout se cantonner à n'être que des correctifs, mais ne changeant rien au modèle en soit. Quand vous avez acheté l'iPhone 4, possédait il un GPS? Possédait il Siri? Possédait il FaceTime en 3G? Non, et pourtant vous l'avez quand même acheté. Donc vous saviez que cela ne faisait pas parti de ce que vous achetiez mais vous l'avez pris quand même. Bref, on se plaint trop souvent...

avatar Kevelian 14/06/2012 - 17:23

@petermax, je te souhaite bien du plaisir alors j’ai 7 des derniers Android sur mon bureau (pour des test) , y en a pas un pour sauver l’autre. exemple Xperia S il est livré avec un OS de 3 génération en arrière et Sony a repoussé aux calande grecque la mises a jour promise en juin …HTC, LG essaye de faire un ScreenShot et les autres j’en parle même pas. ha et surtout n’essaye pas de synchroniser en local tes contacts Android c’est plein de truc sympa seul problème ils sont tous bancale c’est ni fait ni a faire. Apple fait Schmire c’est sur, j’ai pas envie de changer mon 4 , sauf si le 5 est une bombe donc plein de truc ne me seront pas offert mais au moins le tel marche nickel et je doit pas entres dans 3 sous-menu pour désactiver la rotation de l’écran

avatar napuconcture 14/06/2012 - 17:47

"je doit pas entres dans 3 sous-menu pour désactiver la rotation de l’écran" Soit tu l'a dans ta barre de notification : galaxy, soit tu met un petit widget pour. "exemple Xperia S il est livré avec un OS de 3 génération" De 1 génération. Pour le reste je te laisse seul juge de tes appréciations.

avatar Kevelian 14/06/2012 - 18:25

@lmouillart, tu va cesser de dire des balivernes ?? soit tu n’utilise qu’un Motorola Star Tac et un Psion 5 et tu prend tes dire des ScreenShot sur le web, soit tu a un sérieux problème , tes widgets ne sont dispo que sur certains appareils et ils ne sont pas pour toutes les fonctions: genre tu a un widget pour ouvrir/fermer le Bluetooth génial … mais quand tu l’allume ben tu doit entrer dans les sous menu pour dire au machin a quoi il doit se connecter même si c’est a un appareil déjà connu ou un widget pour couper le volume GENIAL mais ça ne coupe que la sonnerie du téléphone et le SMS a 3 plombes du mat lui il va pas oublier de te réveiller. Je suis malheureusement contraint de me servir des ces foutu Android pour encore quelques temps si tu veux je te fait des screencast des fonctions a la noix sur les Droid , des surcouches fabricant codé avec les pieds par une bande de nerd boutonneux qui pensent que tous les utilisateurs ont envie de passer 6heures pour télécharger des trucs horrible pour utiliser seulement 50% des fonctions de base de l’appareil et je te parle pas de toutes leurs aberrations. Fait moi plaisir va sur XDA lire les coms des utilisateurs qui ont leur bouzin planté parce-qu’ils ont voulu installer des Rom super extra de la mort et qui font que tous les deux mois ils doivent faire des restaurations complète. Tu aime le libre c’est ton droit, mais soit un peu objectif tu a tout a y gagner.

avatar napuconcture 14/06/2012 - 23:04

La seule chose que j'ai compris de ton texte c'est que les nouveau wifi sont accessible soit via la barre de notif, soit dans : 1 entrée : preference 2 entrée : wifi. Si les gens bidouillents leurs trucs n'importes comment sur XDA et qu'ils plantent leurs smartphone c'est leur souçis, si ils ne savent pas faire bah ils ne touchent pas ou ils le font dans un émulateur. "widget pour couper le volume GENIAL mais ça ne coupe que la sonnerie du téléphone et le SMS a 3 plombes du mat lui il va pas oublier de te réveiller." Tu le met en profil silence ou vibreur, et c'est bon non ? " des surcouches fabricant codé avec les pieds par une bande de nerd boutonneux qui pensent que tous les utilisateurs ont envie de passer 6heures pour télécharger des trucs horrible pour utiliser seulement 50% des fonctions de base de l’appareil et je te parle pas de toutes leurs aberrations." Celles que je connais : Motocast, Sense, TouchWizz, et ASOP ne correspondent pas à ta description.

avatar Korben007 14/06/2012 - 17:04 via iGeneration pour iPhone

C'est étrange qu'Apple privilégie ses modèles les plus récents... Très étrange !!! Le petit côté ingénu de l'article est un peu surprenant. Les articles de macGé plutôt fondés.

avatar fks86 14/06/2012 - 17:08 via iGeneration pour iPhone

Rappelez moi, combien d'android sur ICS? sorti depuis....

avatar napuconcture 14/06/2012 - 17:18

Maintenant il doit être disponible sur plus d'une 50ène de modèles rien que chez Samsung, HTC, Sony, Motorola

avatar Kevelian 14/06/2012 - 17:31

@lmouillart, tu va cesser de dire des conn*ries ?? : Xperia S il est sous quelle version déjà ??

avatar napuconcture 14/06/2012 - 17:51

Il est sous GB. Mais Xperia S ça fait combien ?? 1 appareil. Tu veux la liste des appareils qui sont sous ICS ? file ton mail par mp, si tu veux je t'aiderais même à les compter un à un. Chez Sony j'ai déjà plus de 10 anciens appareil migrés sur ICS.

avatar winstonsmith 14/06/2012 - 17:57 via iGeneration pour iPhone

@lmouillart : C'est vrai, des dizaines d'appareils Android sont sous ICS. 7%.

avatar napuconcture 14/06/2012 - 23:06

Android ICS est disponible sur la majorité des appareils moyen & haut de gamme vendu l'année dernière. Si les gens ne passent pas les mises à jour c'est un autre souçis. Il faudrait (pour les développeur) faire comme sous Windows forcer les mise à jour mais les utilisateurs râleraient.

avatar eipem 14/06/2012 - 18:34

ICS est l'équivalent d'iOS 5, le premier étant sorti à un mois d'intervalle du second. On reparlera du prochain Android, quand le taux d'adoption aura dépassé 7%

avatar Aleks25410 14/06/2012 - 17:14 via iGeneration pour iPhone

Et puis FaceTime en wifi seulement sur iPhone 4 faut pas abuser non plus. C'est de la mauvaise fois de dire le contraire

avatar mak2 14/06/2012 - 17:14 via iGeneration pour iPhone

Obsolescence programmée ... Le dernier screen shot montre bien la mentalité Apple et leurs produits de merde ...

avatar eipem 14/06/2012 - 17:49

Apple est loin d'être parfaite sur ce coup là, mais elle reste très loin devant Google ou Microsoft. Dois-je te rappeler que le Nexus One, LE premier Google Phone, sorti près de 7 mois après le 3GS ne supporte pas ICS, le dernier Android de Google, sorti il y a 8 mois ? Ta remarque montre à l'évidence le crétinisme sans fond qui t'habite. Je n'ai d'ailleurs pas besoin de t'insulter, tu le fais déjà très bien sans moi.

avatar eldaran83 14/06/2012 - 18:06 via iGeneration pour iPhone

@joneskind : Windows Phone 7 est bien meilleur pour les mises à jour. Tous les appareils sous WP7 ont les mêmes fonctions, sauf 2 appareils : le Lumia 610 et l'Omnia W. Ces derniers n'ont pas le même multitâches. Pour plusieurs dizaines d'appareils différends, Microsoft fait mieux qu'Apple.

avatar eipem 14/06/2012 - 18:15

Les appareils sous WP7 de moins d'un an sont-ils compatibles avec WP8 ? Excuse moi mais on parle ici d'obsolescence programmée parce que les anciens téléphones d'Apple n'auront pas droit à toutes les nouveautés d'iOS6. Je trouve ça facile de cracher sur Apple alors que les voisins font moins bien. Ce qui n'enlève rien au fait qu'Apple va un peu loin dans les restrictions. Le fait est que ICS est l'équivalent d'iOS5, pas d'iOS6. Et que de ce point de vue, Google est très en retard par rapport à Apple. De même, les téléphones WP7 ne sont pas tous compatibles avec WP8.

avatar eldaran83 14/06/2012 - 18:21 via iGeneration pour iPhone

@joneskind : On ne sait pour l'instant presque rien de WP8, ni de sa compatibilité avec les appareils existants.

avatar eipem 14/06/2012 - 18:36

Les constructeurs dont les téléphones seront compatibles avec WP8 l'ont déjà annoncé. Il n'y en a pas beaucoup.

avatar eipem 14/06/2012 - 17:20

Pour la 3D dans Plans sur mon 3GS je ne m'attendais pas à ce qu'elle soit supportée et de toute façon je trouve cette fonction inutile. Par contre le 3GS a bien une puce GPS donc je ne comprends pas bien pourquoi elle n'est pas mise à contribution. Ensuite j'ai aussi du mal à comprendre pourquoi je ne peux plus envoyer plusieurs photos par SMS alors que je peux le faire aujourd'hui !?! D'autant plus qu'on peut aussi réaliser cette opération en faisant un simple copier/coller. C'est absurde. La fonction de partage aussi n'a pas de raison technique d'être absente. Et la liste VIP, la liste de lecture hors connexion... Non là je ne vois pas. J'ai vraiment du mal à trouver la moindre circonstance atténuante à Apple sur ce coup là. Heureusement que je me prends un iPhone 5 dès sa sortie ^_^ PS: à iGé/MacGé pourquoi est-ce que vous ne redirigez pas automatiquement les utilisateurs sur leur page précédente après leur identification ? ça fait plusieurs fois que je me dis que c'est pénible. D'ailleurs, si je me contente de faire "précédent" j'apparait comme déloggué...

avatar MollyPJ11 14/06/2012 - 17:55

J'avoue que je ne comprends pas non plus pourquoi on ne pourra plus envoyer plusieurs photos par SMS avec le 3GS... y a quelque chose qui me dépasse, là... En espérant que cela soit réglé dans une prochaine beta

avatar frondot 14/06/2012 - 17:20 via iGeneration pour iPhone

Et quand est il de la batterie sous IOS6 ?

avatar eldaran83 14/06/2012 - 17:36 via iGeneration pour iPhone

@DeadEye0112 : Je viens de vérifier sur le site d'Apple, et c'est en effet compatible.

avatar pierre64f1 14/06/2012 - 17:26

En résumé : pour un iphone 4 ou un ipad 2, iOS 6 n'a aucun intérêt. Autant rester sur iOS 5 et utiliser des services annexes (un vrai GPS, garder google maps, dragon search et dictée...)

avatar winstonsmith 14/06/2012 - 17:43 via iGeneration pour iPad

@pftlyon Encore une fois, reste sous iOS 5, et d'ici janvier-février 2013, tu auras une petite file d'attente d'apps ne pouvant pas être mises à jour car nécessitant iOS 6... Toujours une histoire d'API et de développemeny... Les nouvelles fonctionnalités ne sont que la partie émergée de l'iceberg. Exemple : les dernières versions MacG mobile incompatible avec les anciennes versions d'iOS. lmouillart, qui adore parler d'API, pourrait confirmer s'il n'était pas occupé à troller.

avatar napuconcture 14/06/2012 - 17:58

Je confirme. C'est sur ce point que l'utilisation de l'api 1.6 ou 2.1 pour Android alors qu'on en est à la 2.3.X 3.X ou 4.X et bientôt 4.1.x ou 5.x est pas mal. Oui il y a de la fragmentation mais c'est mon point de vue ce n'est pas un souçis. Ce qui pose souçis c'est quand les opérateurs ne passent pas les mises à jour de sécurités. Ce qui va faire mal c'est quand les développeurs passeront à la 4 comme version de base. ----- Pour iOS c'est la même chose, est la dessus Apple est mauvais ne pas être capable de maintenir des ABI ou au moins des API sur 2-3 c'est du délire. ------ D'un point de vue déploiement en entreprise j'attends beaucoup de Windows 8, si dans 10 ans je peux acheter un bidule et faire tourner mes apps sans souçis ça sera gagné pour Microsoft, sinon cela sera une nième plateforme mobile pour jouer.

avatar eipem 14/06/2012 - 17:56

Le nouveau Plans d'Apple a quand même une différence majeure avec l'ancien même sur le 3GS: des cartes disponibles hors-connexion et vectorielles. Ensuite, iOS6 n'interdit pas l'utilisation de TOM TOM ou Navigon, ni de Dragon Search ou Dragon Dictation. Et la nouvelle app téléphone est plutôt pratique. Donc j'ai beaucoup de mal à comprendre ton raisonnement.

avatar Dewy 14/06/2012 - 18:48

T'utilise souvent FaceTime en 3G ? Personnellement je l'ai utilisé 5 fois seulement depuis que j'ai mon iPhone 4 ( 2 ans maintenant).

avatar Ellipse 14/06/2012 - 18:03

"Je voudrais simplement faire remarquer qu'il est difficile de faire avaler à un utilisateur d'iphone 4s qu'un iPhone 3GS puisse avoir accès aux mêmes fonctions." Facepalm. Le même mec qui avalerait pas qu'un 3GS ait accès aux mêmes fonctions, c'est un gros connard qui va pas plus loin que le bout de son nez. Une boite comme Synology ajoute l'ensemble des fonctions sans aucune restriction (sinon technique) d'une MAJ sur ses NAS jusqu’à 4 ans, sachant que les modèles sont renouvelées... tous les ans, comme Apple. Et je te garantie que le gars qui a un modèle 2012, il est bien content, parce que justement, il sait que jusqu'en 2016, Synology fera en sorte de retarder au maximum obsolescence de son matos. Pourtant, Synology est une TPE sans le sous à coté d'Apple. Donc justifier ces méthodes marketing absolument délirantes, j'ai beaucoup de mal. Parce que pas de nav GPS ou Facetime 3G sur du matériel frôlant les 700€ il y a encore quelques mois, on est carrément dans le délirant. Bientôt, si on a pas un Mac 2012, on aura une MAJ OS X allégé sous prétexte que bon, on a l'ancien modèle 2011. Et on dira ce qu'on veut sur Android mais: - Les apps Google sont indépendantes de la version de l'OS et MAJ sans aucune restriction et finalement, c'est le plus important. - N'importe quel Android peut tourner sous ICS grâce à la communauté et ce en étant en conformité avec le contrat de Google grâce à l'AOSP.

avatar eipem 14/06/2012 - 18:26

Le Nexus One ne peut pas faire tourner ICS. La communauté s'y casse les dents. Et c'est à Google d'assurer le suivi de son Google Phone. C'est pas comme si c'était un obscur constructeur totalement indépendant. Je ne vois pas ce qu'il y a de gratifiant à dire "Bon on laisse tomber le développement de notre Google Phone (qui a dit obsolescence programmée?) mais si vous voulez vous pouvez le faire vous même". Le Jailbreak est là pour apporter ce qui manque à iOS, et ce n'est pas plus illégal. La communauté se porte d'ailleurs très bien.

avatar MollyPJ11 14/06/2012 - 17:53

Je trouve franchement abusé que Facetime en 3G ne soit pas compatible avec l'iPhone 4, tout comme la fonction GPS ! Autant la 3D et Siri, à la limite, mais ça, ça passe pas très bien.

avatar jantiochus 14/06/2012 - 18:05

C'est vraiment dommage pour FaceTime en 3G ... Tant pis, je continuerai d'utiliser Skype lorsque je ne capte pas de Wifi ...

avatar Ellipse 14/06/2012 - 18:39

"Apple se doit de faire évoluer ton iPhone que tu as acheté un prix donné pour des caractéristiques données?" Tout le monde rabâche qu'avec Apple, tu es sûr d'avoir un suivi de ton matos, des MAJ, etc, contrairement à Android (et souvent à raison). Ca sert à quoi si Apple vire tout l’intérêt des MAJ en question ? Surtout, comme expliqué plus haut, sur Android, si l'OS n'est pas MAJ, les apps et donc les fonctionnalités importantes le sont toujours, quelques soit la version de l'OS ou l'ancienneté du terminal.

Pages