L'App Store se ferme aux applications pour iPhone OS 2

Florian Innocente |

Apple enjoint les développeurs d'applications iOS à s'assurer que leurs réalisations sont compatibles avec iOS 4. D'autant plus que celui-ci est disponible gratuitement pour iPhone mais aussi pour iPod touch.

Le blog développeurs d'Apple précise que les applications doivent être absolument compilées avec la dernière version 4 du SDK. Les logiciels compilés expressément pour l'ancienne version 2 d'iPhone OS ne seront plus acceptés sur le store. Cette version d'OS date de l'été 2008, elle avait amené avec elle le principe des applications natives et de l'App Store.

compileios4

avatar adriii | 
Tant mieux, que les dev commence a tiré parti de toute les possibilité d'iOS4 ! Car il suffit des dix doigts de la main pour compter les applications optimisé pour l'iPhone 4. C'est comme la résolution des icônes d'app. Sur iTunes elles sont net et sur l'iPhone 4 c'est flou avec le rétina display (et ça fait laid). Steve Jobs disait lors de la Keynote que l'iPhone 4 ajustera lui même les graphisme et que le développer n'avait pas vraiment a s'en préoccuper. Mais il s'occupe d'ajuster les écritures c'est tout. J'espère seulement que le dév. se seront aussi rappelé que Jobs a dit qu'il serait mieux de le faire. En tout cas déçu de ne pas pouvoir profiter comme il ce doit de l'iPhone 4 !
avatar dumas75 | 
Ne te plains pas! Toi t as 1 iPhone 4, au moins! ;)
avatar adriii | 
Oui je sais mais c'est quand même vachement frustrant, perso j'ai trouvé que iBooks, Twitter, Evernote, GodFinger en app gratuites optimisé pour le rétina display. Et l'App Store affiche des icônes d'application flou même pour des applications qui ont un bon rendu sur l'iphone 4....
avatar PtitRital67 | 
ouais enfin avant de vouloir des applis optimisées iOs4 j'aimerai déjà en avoir des compatible vu le nombre d'appli qui plante sous iOs4
avatar mixo001 | 
c'est une très bonne nouvelle, les possibiliés du sdk pour fonctionner sur ios 2 étaient vraiment super limités par rapport à ios 3 et par dessus tout ios 4
avatar Lou117 | 
Vu que la mise à jour est quand même pas évidente pour tout le monde, c'est un peu chiant de limiter à l'OS 4... :/
avatar 2fast | 
L'OS 3 est toujours supporté.

CONNEXION UTILISATEUR